Come scrivevo nel post precedente, dopo quasi un anno sto tornando ad usare Linux a tempo pieno, e nello specifico Debian. Ecco quindi il perchè del titolo di questo post; chi mi seguiva un minimo, sa che uso Debian da anni e quindi la sua installazione non è un problema, ma dopo circa un anno di “assenza”, sicuramente un bel po’ di ruggine si è formata, ed ecco il report del mio “ripristino”..

Dopo aver scaricato dal sito ufficiale la ISO di Debian 7.1 versione netinst, ovvero la versione che necessità della connessione ad Internet (via cavo) per funzionare, e dopo averla messa su un pendrive, via con l’installazione vera e propria, che devo dire mi ricordavo abbastanza bene, e che non è cambiata di una virgola. Scelgo di non installare praticamente nulla al di fuori del sistema base, in modo da poter poi “plasmare” la distribuzione come meglio credo.

L’installazione è stata effettuata sul mio Samsung NP350V5C-S0AIT, praticamente questo giocattolino qui.

Joif_-_debian_logo_stickerPoi, dato che comunque resto un tipo non da stable, ho provveduto a cambiare i repository in testing (meglio non lanciarsi immediatamente alla sid che usavo tempo fa), aggiungendo le fonti contrib e non-free, per poter contare su un database di pacchetti ragguardevole.

In sequenza:

  • dopo essermi loggato come root,
    apt-get upgrade

    per passare da stable a testing;

  • ho cercato di installare aptitude (sempre in omaggio al voler procedere senza strafare), ma ho riscontrato con piacere che era già installato;
  • aptitude safe-upgrade && aptitude full-upgrade

    il secondo non ha aggiornato nulla in realtà;

  • update-grub
  • aptitude install xorg xfce4 lightdm build-essential linux-headers

E già, ho scelto di usare XFCE come desktop environment. Era una scelta che avevo fatto a suo tempo seguendo l’esempio degli sviluppatori, che per ragioni di spazio (soltanto?) avevano deciso di passare a questo ambiente. Inoltre, aggiungo il minimo indispensabile per compilare qualche pacchetto, e gli headers del kernel che mi ha installato, versione 3.10-2.

Successivamente, per iniziare la personalizzazione, ho eseguito i seguenti passi:

  • installazione e configurazione di sudo
  • Iceweasel + Icedove (browser e email)
  • Flashplayer
  • firmware Atheros per la mia scheda WiFi + Wicd come gestore di reti
  • Intel-microcode (in risoluzione ad un errore in avvio riscontrato con dmesg)
  • pacchetto xfce4-goodies per ottenere un bel po’ di futilità essenziali ( 🙂 ) per l’ambiente grafico
  • pacchetto esound per abilitare l’audio
  • attivazione del compositore di finestre di xfce

Direi che per ora funziona tutto alla grande, e di ruggine forse ce n’è meno di quanto pensassi, ma la sfida (?) sarà forse col sistema grafico, poichè si tratta di un dual graphics Intel/AMD (dovuto alla CPU I7 di 3a generazione). In realtà sembra funzionare tutto, ma devo capire bene la situazione. Drivers open ne esistono? O devo ricorrere ai proprietari? Si accettano consigli ovviamente!! 😉

Alla prossima..

Share
Molto scarsoScarsoSufficienteBuonoOttimo (Nessun voto)
Loading...

Licenza

Creative Commons License
RedBlue's Blog di RedBlue è rilasciato sotto licenza Creative Commons 2.5 Italia.

Badges

Cionfs'Forum CMS Check PageRank

Other

Se hai trovato utile questo blog, supportalo con una piccola donazione per l'hosting..


Locations of visitors to this page